Aero Guarder now available on App Store


Apple requires all approved lightning earphone products to include a corresponding iOS app to upgrade its microcontroller firmware inside the earphone. Aero Guarder is our little utility to do this job. The first time when you plug in your Aero lightning earphone to your iPhone/iPad, it will prompt you to install this utility. You can skip it and install it later if you want. We will issue new app upgrade with new MCU firmware included if needed.

Featured Posts
Recent Posts
Archive
Search By Tags
Follow Us
  • Facebook Basic Square
  • Twitter Basic Square